Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Dock position lost on restart

+1 vote

Hi,

Each time I start yEd, it remembers the windows that were docked when I closed the application, but these docks are not where I moved them.

What can I do so yEd remembers where I put the docked windows?

yEd 3.12.2, Java 1.7.0_55

Here are screenshots of yEd before closing and after restarting.

asked May 15, 2014 in Help by bcroq (370 points)
edited May 16, 2014 by bcroq
Could you add two screenshots (one showing the docked components at the desired location and one showing the locations after restarting yEd) illustrating the problem?
As requested, I have just added a link to screenshots.

2 Answers

0 votes
Thanks for posting; this is also happening to me.

Edit: If it's useful, I was coming from v3.10.
answered May 20, 2015 by anonymous
I've found that deleting all my user prefs did the trick.
> deleting all my user prefs

Unable to reproduce this fix  : (
0 votes

Also reproducible in 3.14. I'm about to get the latest version (3.14.2 at this time) and try again.

Update: ...Not fixed in 3.14.2. Arranged my docked dialogs as I want them and closed 3.14. Updated program (running standalone JAR on Windows) and reopened, dialogs are all dumped into a tabbed panel on the left side instead of how I left them. (Not 'Structure View' though...). Re-arranged and closed and re-opened again, and everything is once again piled up over on the left.

Now trying the 'delete user prefs' suggestion from the 05/27 comment.

Update update: Well there's no option in the UI called 'Delete Preferences' or any variation thereupon, but I tried 'Reset Layout' from the Windows menu, then recreated my desired layout, then restarted. It was discarded again. Also tried deleting "yed-3_5.layout" from my %AppData%\Roaming\yWorks\yEd, and even deleting everything from ...\yEd\, both to no avail.

answered Jun 30, 2015 by gws (260 points)
edited Jun 30, 2015 by gws
No luck in 3.14.3 either. I wonder why it's working for everyone but us?
Legal Disclosure | Privacy Policy