Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Categories

Recently save flowchart opened with diagram overlayed

0 votes

Hi,

I had made a large flowchart diagram, saved and then later tried to open it.
When the file is opened I was prompted to choose:

and once the file opened this is what it looks like:PromptCrash

Did I just loose all my hard work?

in Help by

1 Answer

0 votes

The TGF file format only stores the diagram structure (i.e. how many nodes are there and which nodes are connected) and the text of the first label of each node and edge. I.e. if you save a diagram in TGF format, you discard any visual and geometric information. To prevent this from happening accidentally, yEd always asks for confirmation in this case:

That said, you did not loose all of your work. As I said, the structure of the diagram and the text of the first label of each node/edge is still there. Thus it should be possible to recreate your previous diagram with some effort (but not as much effort as creating it from scratch). I suggest the following approach:

  1. Use "File" -> "Save As" to save your diagram in GraphML format.
  2. Run "Layout" -> "Hierarchic" with default settings.
  3. Replace the simple rectangle styles with the appropriate flowchart styles. To do that, select one or more nodes, go to the flowchart palette section, right-click the desired flowchart style, and choose "Apply".
  4. Correct the size of your nodes.
  5. Run "Layout" -> "Flowchart".
  6. Manually adjust the positions of your nodes if necessary.
  7. Correct remaining visual features such as color.
by [yWorks] (138k points)
Thank you for the answer. I did explore that option but still it is not the best.

Maybe I am just too dumb but this " if you save a diagram in TGF format, you discard any visual and geometric information" should be a notifier when ever someone elects to save files in tgf format. Especially for someone novice like me.

And their should also be suggestion to save files in "GraphML" stating "if you would like to preserve the structure.
Legal Disclosure | Privacy Policy
...