Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Tree Hierarchy Node unsorted?

0 votes
HI!

 

I tried to import an excel sheet with multiple labels like (N3Z, A2K, H1K) etc

They are always blocks of 3 letters; usually multiple blocks following each other.

Like :  H4N E8O K9A

etc

 

I am trying to reverse the tree structure so I can see, which is most often. Which follows always what. etc

 

But afer doing this and getting the graph, I see no correlation between numbers of the node and my sorting even  I specifically mark the colum.

 

How can I do this??
asked Nov 14, 2016 in Help by anonymous

1 Answer

0 votes

The sorting in the Excel file has no effect on the layout of the imported diagram. Indeed, the layout is based on the structure of the diagram only. (In this context, structure means "which elements are connected".)

If you want to emphasize elements by their connection count, use "Tools" -> "Centrality Measures" with default values.

Aside from the "Centrality Measures" tool, yEd does not offer much in the way of automated structure (or content) analysis.

answered Nov 14, 2016 by thomas.behr [yWorks] (120,480 points)
no thats not exactly what I meant

Why doesnt it use my description/Text in the Excel file? It seems he uses random numbers.

Cant I say use the Excel text?

I mean the Excel is sorted already and he is also importing the data with corresponding amount of nodes and all but the numbers on the nodes dont correspond to the Excel file, as it seems.

yEd never uses "random numbers" when importing data from Excel.

Since your problem seems to be specific to your data, would it be possible for you to upload your Excel spreadsheet, a screenshot of your Excel import settings, and the resulting diagram in GraphML format here? (See How to upload files to yEd Q&A? for related documentation. Please do not start a new topic, but upload your files in this thread. Please do not upload files with sensitive data.)

HI!

did the screenshots but cant upload it because the uploadshows me a broken Screen?!

also new question or answer doesnt work

only see upload as button and a white/blank space

Re:

did the screenshots but cant upload it because the uploadshows me a broken Screen?!

Well, then upload the Excel file and the GraphML file only.

Re:

also new question or answer doesnt work

I just answered another question and was able to upload screenshots without problems (see Import Excel: Group Name not importing correctly).

Re:

only see upload as button and a white/blank space

What exactly did you do? Did you click "answer" right below your original post, write some text in the editor area, select the text, and click the "link" button?
 

yes I did try all 3 Options (answer, reply, new Topic)

here at mybucket:

http://s270.photobucket.com/user/eraser51/slideshow/yed

OR

<div style="width:480px;text-align:right;"><embed width="480" height="360" src="http://pic2.pbsrc.com/flash/rss_slideshow.swf" flashvars="rssFeed=http%3A%2F%2Ffeed270.photobucket.com%2Falbums%2Fjj108%2Feraser51%2Fyed%2Ffeed.rss" type="application/x-shockwave-flash" wmode="transparent" /><a href="javascript:void(0);" target="_blank"><img src="http://pic.photobucket.com/share/icons/embed/btn_geturs.gif" style="border:none;" /></a><a href="http://s270.photobucket.com/user/eraser51/library/yed" target="_blank"><img src="http://pic.photobucket.com/share/icons/embed/btn_viewall.gif" style="border:none;" alt="eraser51&#039;s yed album on Photobucket" /></a></div>

maybe this will help

The configuration depicted in

does not match any of your result screenshots!

Please note, with the data ranges you have specified only a single node will be imported (and that node will be a group node)!

Please read Import of Excel Files to get a basic understanding of how Excel import works.

That said, the most obvious errors in your configuration are:

  1. In the edge list settings, you are using the same column for source and target ID. Source and target should always be two separate columns.
  2. In the edge list settings, you have "Property Names in First Row" (or rather "Eigenschaftsnamen in erster Zeile") enabled - even though your first row does not  contain names but data.
  3. In the node list settings, you are using the same column as node IDs and group node IDs. Your data does not seem to be hierarchically organized, you need to leave the field for group node IDs empty.
  4. In the node list settings, you have "Property Names in First Row" (or rather "Eigenschaftsnamen in erster Zeile") enabled - even though your first row does not  contain names but data.

 

Once again, Excel import never generates diagrams whose nodes are sequentially numbered (unless that sequential numbering is actually data in one of the spreadsheet's columns). Your "results" look very much like they were generated by yEd's tree generator from "Tools" -> "Create Graph" -> "Tree".

I strongly recommend you start with a (very) simple example (like the one in the manual or the one depcited in my answer to Import Excel: Group Name not importing correctly) to get familiar with Excel import.

Imprint | Privacy Policy