Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Interface Malfunction with last yEd version (3.13)

0 votes

Hi,

There's a big problem with the last version.

The letter disappear when I glide my mouse over them.

It happens with  every element who have some text on it. Some screenshot to describe better this problem :

 

Also it is very hard to edit a label as there is no cursor when in edit mode :

 

So, I'm forced to use a previous yEd version as this is not possible to work with this one.

 

Do you have any idea where could be the problem ?

 

Thanks,

 

Olivier

asked Oct 31, 2014 in Help by anonymous

Unfortunately, we do not have any ideas what is causing these problems. Which exact version of Windows and Java are you using (see "Help" -> "About")?

If you installed the yEd version that comes with an embedded Java runtime, try running yEd with
"C:\Program Files\yWorks\yEd-3.13\jre\bin\java" -Dyed.laf=crossplatform -jar "C:\Program Files\yWorks\yEd-3.13\yed.jar"
from the command line. If you installed the yEd version without an embedded Java runtime, try
java -Dyed.laf=crossplatform -jar "C:\Program Files\yWorks\yEd-3.13\yed.jar"
on the command line.

This starts yEd with another theme. Does the alternative theme work?

1 Answer

0 votes

I have the same problem with these versions:
http://www.yworks.com/en/products_download.php?file=yEd-3.13.zip
http://www.yworks.com/products/yed/demo/yEd-3.13_without-JRE_64-bit_setup.exe
http://www.yworks.com/products/yed/demo/yEd-3.13_with-JRE_32-bit_setup.exe
http://www.yworks.com/products/yed/demo/yEd-3.13_with-JRE_64-bit_setup.exe

I'm working on Win7 Professional SPI, 64bit with

java version "1.8.0_05"
Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
Java HotSpot(TM) Client VM (build 25.5-b02, mixed mode

and I also tested with

java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot(TM) Client VM (build 25.25-b02, mixed mode)

I have this problem, if I just double click the yed.jar icon and start with the default theme (I case of the Zipped yEd Jar file), open the yed.exe
and also if I run it in the command line with:
java -Dyed.laf=crossplatform -jar "PATH_TO_FILE\yed.jar"


The Solution for me was to change back to java version 1.7 update 71 64bit !
Java 7 installation you can find under http://java.com/de/download/manual_java7.jsp

Now version http://www.yworks.com/products/yed/demo/yEd-3.13_without-JRE_64-bit_setup.exe
is working for me!
 

answered Nov 1, 2014 by anonymous
quote: "

For those whose problem has not been solved; try this solution:

Set the global environment variable "J2D_D3D" to "false" inside the OS. According to Sun, this setting is used to turn off the Java 2D system's use of Direct3D in Java 1.4.1_02 and later.

ie: simply create a environmental variable with name "J2D_D3D" and value "false" without the quotes.

this has solved my rendering problems, hope it does yours also.
"
from http://stackoverflow.com/questions/22737535/swing-rendering-appears-broken-in-jdk-1-8-correct-in-jdk-1-7

helped me! Maybe its worth a try.

A slightly simpler solution offered in the above thread is using the command line option -Dsun.java2d.d3d=false when starting yEd.

Imprint | Privacy Policy