Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

ubuntu 14.04 install yEd 3.12.2 64bit

0 votes
ubuntu 14.04 beta2 64bit, install 3.12.2 64bit, install is OK, when started, show the dialog ask me select the new document, open document, etc. Now if select the new document, then the dialog disappear but no yEd UI showing.

I install and uninstall sometimes, is same and i try to sudo ./yed and ./yed, also same problem.

pls help, thanks.
asked Apr 11, 2014 in Help by jerry79 (120 points)
Which desktop environment are you using? Can you please add screenshots that show the application after you have clicked "New Document"?
pls follow these picture
1、when I start yed, no main window, only show new, open
https://www.dropbox.com/s/5vjb4ar8iezycn1/%E9%80%89%E5%8C%BA_091.png
2、when I click the new or open a old file, no anything showing
https://www.dropbox.com/s/tkvjcfp7kkqwsoy/%E9%80%89%E5%8C%BA_092.png?m=
I installed ubuntu 14.01 and yEd yEd-3.13_64-bit_setup.sh with unity and have the same problem. I found out a bit more about the problem: I have a laptop with a docking station and a second screen. Only in this configuration does the problem occur. It does work if I undock the docking station. (Lenovo L430, Intel graphics device).
same problem here, ubuntu 14.10 -yed 3.13_64-bit or yed.jar

Re:

I have a laptop with a docking station and a second screen. Only in this configuration does the problem occur. It does work if I undock the docking station.

Well, this very much points to a low-level hardware/operating system/Java integration issue. Your best bet is installing the latest Java version from Oracle and using the zipped yEd jar with that Java version. This kind of problem is basically impossible to fix on the yEd side of things.

I've downloaded the zip and tried starting it with both java 7 and java 8 from oracle. I still get the exact same problem.

What display server are you using? Mir? If so, you might be running into this problem. Unfortunately, this cannot be fixed in yEd. Either the (X)Mir development team has to incorporate a workaround in Mir or Oracle has to fix the problem in Java.

1 Answer

0 votes
go to Synaptic Pakage Manager

Search for graphviz

install the first 3 elements

re-run the yEd again

have fun
answered Sep 30, 2014 by anonymous
I have tried this solution and searched for 'graphviz' in Synaptic PM. Since the solution above does not specify exactly which packages should be installed I have installed everything that has graphviz in name along with dependencies:
   graphviz
   libgraph-writer-graphviz-perl
   ruby-graphviz
   graphviz-doc
   graphviz-dev
   libgraphviz-perl
   libgraphviz-dev

After reinstalling the uEd (3.13 64bit on Ubuntu 14) and execution, it still exhibited the symptoms as described in this thread.

What package precisely is lacking and should be installed to yEd to operate properly?
Imprint | Privacy Policy