Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Installation fails on a Linux system

0 votes

Hello everyone,

I'm trying to install yED on my Linux System and getting the following error:

Unpacking JRE ...
Preparing JRE ...
Starting Installer ...
java.lang.UnsatisfiedLinkError: /home/.../yEd-3.11.1_32-bit_setup.sh.13618.dir/jre/lib/i386/xawt/libmawt.so: libXtst.so.6: cannot open shared object file: No such file or directory
(followed by a long list of consequential errors)
 
Java 6 is not installed anymore and I assume this causes the error.
 
Are you currently working on a new version which uses Java 7?
 
Kind regards
 
 
 
asked Nov 20, 2013 in Feature Requests by anonymous

1 Answer

0 votes
 
Best answer

The installer does not require a Java installation at all. The problem is that you are trying to install the 32 bit version on your 64 bit machine.

I suggest trying the 64 bit installer instead of the 32 bit installer ...

 

You could also install 32 bit compatibility libraries ia32-libs, but I do think using the appropriate installer is the better approach. ;-)

answered Nov 20, 2013 by thomas.behr [yWorks] (122,690 points)
Imprint | Privacy Policy