Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

java.lang.UnsatisfiedLinkError when installing on Ubuntu 12.04 64bit

0 votes

On Ubuntu 12.04 64 bit trying to install with yEd-3.10.2_32-bit_setup.sh gives the following error:

Unpacking JRE ...
Preparing JRE ...
Starting Installer ...
java.lang.UnsatisfiedLinkError: /home/david/Downloads/yEd-3.10.2_32-bit_setup.sh.746.dir/jre/lib/i386/xawt/libmawt.so: libXrender.so.1: cannot open shared object file: No such file or directory
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
...

I would be greatful for any hints!

Edit: libXrender is installed and lies in /usr/lib/x86_64-linux-gnu/libXrender.so.1
 

asked Apr 25, 2013 in Help by anonymous

1 Answer

0 votes
 
Best answer

I suggest trying the 64 bit installer instead of the 32 bit installer ...

 

You could also install 32 bit compatibility libraries ia32-libs, but I do think using the appropriate installer is the better approach. ;-)

answered Apr 25, 2013 by thomas.behr [yWorks] (127,030 points)
Of course... I missed the link to "Weitere Downloads...".
Legal Disclosure | Privacy Policy