Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Categories

How to select preceding nodes and edges

0 votes

Selecting predecessor nodes and edges with the “select elements” tool is a multi step process.

I made a “how to select nodes and edges” video to help Users.

https://youtu.be/4bKpJif71Hg

These are the steps used to highlight nodes and edges. Are they the most efficient?

  1. Select Predecessor Nodes
    1. (A)Select a node
    2. Tools→Select Elements
      1. General Tab= nothing checked
      2. Nodes Tab settings
        1. Select: “Predecessor of selected Nodes”
        2. Maximal Path Distance = {number of predecessors to select} 
        3.  OK (or Apply, if docked)
      3. Edit→Raise Selection
      4. Make changes to node colors and properties
      5. Clear selected nodes
        1. Edit→Unselect all
  2. Intermediate step
    1. Select the starting node from step 1a
    2. Tools→Select Elements
      1. General Tab= Select Inverse
      2. Nodes Tab settings
        1. Select: “Predecessor of selected Nodes”
        2. Maximal Path Distance = {number of predecessors to select} 
        3. OK
    3. Shift +left Click to deselect node in step 2a
  3. Select Edges
    1. Tools→Select Elements
    2.  General Tab= Select Inverse
    3. Nodes Tab = uncheck “Use this Criteria”
    4.  Edges Tab settings
      1. Check “Use this Criteria
      2. Select: “Selected Nodes”
      3. OK
    5. Make changes to edge colors and properties

Thanks

in Help by

1 Answer

0 votes

I think step 1.3. "Raise Selection" is unnecessary and selecting predecessor edges can be achieved with less steps:

  1. Use "Select Elements" to select a node and its predecessor nodes as described in steps 1.1. to 1.5.
  2. Use "Select Elements" to select "Selected Nodes Subgraph Edges".

For the second step, make sure none of the options on tab "General" are active. Additionally, option "Use These Criteria" may only be active for tab "Edges".

by [yWorks] (153k points)
Thanks for sharing the better way to select predecessor edges.  You are correct, the "Raise Selection" step isn't necessary.  It's a preference to have the selected edges on top.  Your answer is appreciated. Thanks!

Re.:

You are correct, the "Raise Selection" step isn't necessary. It's a preference to have the selected edges on top.

For completeness sake, I would like to mention "File" -> "Preferences", tab "Display", option "Draw Selected Elements On Top". With that setting enabled, yEd will automatically raise selected elements and lower them once again when they are no longer selected.

Legal Disclosure | Privacy Policy
...