Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Categories

can't save file after format change during save

0 votes
sorry there is no category bugs.

sorry this might have to go elsewhere (if there is a category bugs elsewhere)

when I say "save as" of an existing file and want to change name in the save as dialog.

default file format is .ygf -all fine then hit ok

then yEd asks me whether I really like ygf or not rather tend to save as graphml.

OK choose graphml.

==>> then the file does not get saved as .graphml format (!!!)

I lost my diagram due to this.

If you insist on .ygf format during the dialog the diagram will be correctly saved.

the issue is reproducible and seems rather to be a bogus to me.

Please fix this.

I want to have a perfect yEd!

greetings! :-)
in Help by
recategorized by
Which version of yEd are you using? Which version of Java is yEd running on? And finally, on which operating system are you running yEd? (See yEd's "Help" -> "About" for the first two questions.)
sorry maybe I should rather answer on this question than add a new comment... sorry still learning. :-)
----
-> repost answer:
-----
Hello QA-Team!

used version is: 3.9.0 -> issue reproduces still under 3.9.2

java version is according to shell output (java -version):

java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.1) (6b24-1.11.1-4ubuntu3)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
 

OS: ubuntu 12.04

Hope this helps!

:-)
The shell output is only relevant if you did not use the install script, so please use the method I mentioned above ("Help" -> "About") to check the java version!

Anyways, OpenJDK is *NOT* supported. Please run yEd on the official Oracle Java. You can download the most recent Java SE 6 (update 33 as of this writing) from http://www.oracle.com/technetwork/java/javase/downloads/index.html (it suffices to download and install the JRE).

That said, I was able to reproduce the problem and have filed a corresponding bug report.
I *did* not use the install script to run yEd:
java -jar yed.jar

that open JDK is not supported I did not know. sorry for not doing rtfm homework. sInce *anything else* runs just fine under openJDK I was convinced this was a bug and no need to try with official versions.

Either way:
I can reproduce the behaviour under official Java versions, too.
yEd Info-about says:
"Java Version: 1.6.0_21
Java VM: Java HotSpot(TM) 64-Bit Server VM, Sun Microsystems Inc."
Unfortunately one can not copy and paste this info...

The behaviour reproduces identically under
"Java Version 1.7.0
Java VM: Java HotSpot(TM) 64-Bit Server VM, Oracle Corporation"

yEd is one of my favorite tools for years now.
As this to me occurs a real and important issue I did efforts to report.
Some additional data I forgot and delivered in the way you wantd it by now.

I feel upset and impatient as it feels so long and hard to proove this is really an issue.
This is of course partly because I did not provide you with the required data. For which I am sorry.

I please you to have a look at this so that there can be a fix provided.
I need this tool to run with a proper save as functionality.
> I feel upset and impatient as it feels so long and hard to proove this is really an issue.
Did you maybe miss the last line in my previous comment?

> I need this tool to run with a proper save as functionality.
Although "Save as GraphML" in the format warning is broken, that does not mean "File" -> "Save As" is also broken. You can simply choose "GraphML" as "Files of Type" right away and saving will work fine. (By the way, GraphML *is* the default file format for saving.)
You name it! thanks for filing a report and for pointing out  your last sentence!

Really oversaw it. Reading that would have saved time and nerves.

----

Whereas now I kept playing around and found one more thing that I would consider a minor issue in the same area (save as) but still worth reporting:

Reproducable under open JDK and jdk 1.7.0:

start yEd. Open two already created documents of any format (I used .graphml&..ygf)

For clarity let's call these A and B.

now you have three open: the new empty (default) one plus A and B.

Now close one of the two loaded ones, say B.

The focus will now switch to the remaining loaded document (A).

Now try save as ;-). which will not work as it is grayed out in the menu.

Click to the "new empty" document (on the tab) and back to A to see "save as" enabled again.

This is probably according to some missing kind of refresh as "save as" turns fully enabled again as soon as you click on the "new empty" document and back to the remaining loaded document (A).
You are right! I was able to reproduce this problem, too, and have filed a corresponding bug report. Thanks for the detailed information, it really helps in pinpointing such issues.
No worries! As you can see I needed some learning curve now to become as detailled as needed.
The fun part is that I should have known already: such reports are wellknown to me as I am a Java developer, too. ;-)

So: happy hunting and all the best for yEd! -Greetings!

1 Answer

0 votes
Fixed as of yEd 3.10.
by [yWorks] (147k points)
Legal Disclosure | Privacy Policy
...