Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Error in yED Live since today: The GraphML could not be parsed

0 votes

Hi, 

my name is Robert. I have been working on 3 diagrams in yED Live since November 2nd.

As far as I know, there was a switch to a new version 3.17.1 yesterday. Since this morning I am unable to open my graphml files. When I look at them in Notepad++ they seem intact.

I get the following error messages when I try to open them in yED Live (latest Chrome):

The GraphML could not be parsed

Cannot read property 'insets' of null

I can open the files in yED live 2016 (https://www.yworks.com/yed-live-2016) but it switches to compatibility mode (probably because the client is older than the files). I cannot open them in fat client 3.17.1 (see error message above) or yED live 2017. I was able to do so yesterday though.

Here is one of the files as a sample: click

When I try to open the file in yED fat client 3.17.1 I get these errors:

Screenshot

Please help - I love yED but I need to keep working on these - Thank you!

asked Nov 7, 2017 in Help by anonymous
edited Nov 7, 2017

1 Answer

0 votes

Hi Robert,

please correct me if I didn't understand you correctly: You did end up with GraphML files that won't open in yEd Live and also cannot be opened in yEd Desktop 3.17.1?

Do you remember the last changes to the diagram before it was broken?

Can you provide us with the broken GraphML file? http://yed.yworks.com/support/qa/1734/how-to-upload-files-to-yed-q%26a contains a Step-by-Step instruction on how to include files in your reply. Please note that those files should not contain any sensitive data.

Best regards,

Fabian

answered Nov 7, 2017 by fabian [yWorks] (890 points)
Hi Fabian,

thank you for helping with this. To your first question: Yes that is correct.
The last changes were minor tag label changes. I translated from German to English so nothing fancy. Some of the files weren't changed at all since November 2nd and still won't load. I doubt therefore that the issue is with anything I changed.

I will instantly upload one of the files for you to analyze. You'll find the link in the original post above.

Thank you so much in advance.

Regards,
Robert
Thank you for the GraphML. We were able to identify the problem, which is actually a bug in yEd Live's serialization of the pool node.
We have just deployed a fixed version of yEd Live, therefore the pool node should now be written correctly when saved.

That said, these specific GraphMLs can still not be read by yEd Live (or yEd Desktop). We are trying to make it work despite the faulty pool node serialization. However, this needs some more investigation.

For now, you need to correct the files manually by opening them in a text editor and replacing

<bpmn:PoolNodeStyle __bf="{x:Undefined}">

with

<bpmn:PoolNodeStyle>

i.e. deleting the broken attribute. Then, you can open the GraphML in yEd Live as well as in yEd Desktop and you can also save it as usual in both applications.

Afaik, only the "PoolNodeStyle" should be affected but you can also search for '__' (double underscore) which should not appear as an attribute of an XML tag.

Sorry for the inconvenience and thanks again for pointing us to the issue!

Best regards,
Fabian
Hi Fabian,

thank you very much for your quick response. This solved my problem!
I was able to restore all my diagrams by replacing the string within XML as you proposed.

Thank you again and best regards,
Robert
Legal Disclosure | Privacy Policy