Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

yed 3.16.1 not working on macOS Sierra

0 votes
yEd 3.16.1 does not work on my MacBook since I've installed macOS sierra.

Error is below. yEd 3.15 still works. I have Java 8 update 101

Exception in thread "main" java.lang.UnsupportedClassVersionError: com/yworks/A/B : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)

 

Any tips, or is this an issue that needs fixing at the yed end?
asked Sep 23, 2016 in Help by PhilEvans (330 points)

1 Answer

+2 votes

That error message means that you are trying to run yEd 3.16.1 with Java 6 or Java 7 instead of Java 8 (version 52.0 is the class file version for Java 8). This also explains why yEd 3.15 still works - 3.15 is compatible to Java 6, while 3.16.1 requires Java 8.

Did you install yEd from the Mac OSX disk image (yEd-3.16.1_with-JRE8.dmg) or from the Zip archive (yEd-3.16.1.zip)?
How do you run yEd? I.e. do you manually execute "java -jar /path/to/yed.jar"?

answered Sep 23, 2016 by thomas.behr [yWorks] (111,430 points)
Thanks . I hadn't realised that the command line version of java is not the same as the system java. Installed JDK 1.8_102 and it all works now.
Imprint | Privacy Policy