Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Could not display the GUI. This application needs access to an X Server

0 votes
sudo bash /home/kseb/yEd-3.8.sh
 
Could not display the GUI. This application needs access to an X Server.ubuntu 11.10
asked Dec 22, 2011 in Help by anonymous
edited Dec 28, 2011 by michael

2 Answers

+1 vote
I had exact same problem installing soapUI on my 64 bit Ubuntu 12.04 (precise) system.

First, I uninstalled OpenJDK and installed Oracle/Sun Java 1.7_07 iaw. recommendations on other sites, but to no avail. Still getting error message 'Could not display the GUI. This application needs access to an X Server'.

What solved the problem was installing 'ia32-libs' (which has a dependency to several packages, among them 'ia32-libs-multiarch:i386', which is also installed). After running the installer shell script again, I still got some error messages (ELF versions etc.), but installer GUI actually started anyway. Running the installed (with sudo bash install_script.sh) again, the error messages from previous install were all gone...

Thanks for tips!

/alfs
answered Oct 8, 2012 by anonymous
thanks for your helpful advice - antony.stevens@saude.gov.br
0 votes
Imprint | Privacy Policy