Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Bug with Find tool for several in/out edges

0 votes
Hi,

 

I seem to have a problem with the "Find" tool in selector mode, which is not able to select more than one edge at a time in "Selected Nodes Inedges" mode; when one node with many incoming edges is selected it will pick up one edge, when many nodes are selected it won't do anything. I've changed recently to the 3.12 version of yEd, I don't remeber having this issue before, is there a way to avoid this?

 

Thanks for this tool by the way, it is a great one!
asked Feb 20, 2014 in Help by anonymous

2 Answers

0 votes
Unfortunately, no. This is a regression that was introduced in yEd 3.11.1 and was not discovered until yesterday. It will be fixed in the next yEd release, though. (We do not yet have a date for that release.)
answered Feb 20, 2014 by thomas.behr [yWorks] (121,330 points)
Won't select when searching by Node Labels
0 votes

Sorry, but I totally misunderstood the problem.

"Edit" -> "Find" is meant to select only a single element. "Edit" -> "Find" is meant to be combined with "Edit" -> "Find Next" and "Edit" -> "Find Previous". If there are multiple elements that match Find's criterion, repeated use  of Find Next and Find Previous will cycle the selection through all matching elements.

You are right, though, the green start button does not seem to work when docking Find.

If you want to select all matching elements at once, you need to use "Tools" -> "Select Elements". (And Select Elements is the one that was broken and is fixed as of 3.12.1.)

answered Mar 19, 2014 by thomas.behr [yWorks] (121,330 points)
No, you did answer it well in the first place, I was just pointing out the fact that the Select Tool had a bug. I just got names wrong since the UI are so close. Thanks for the bugfix anyway!
Imprint | Privacy Policy