Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Java 9 Support

0 votes

As there is no proper HiDPI support in Java 8, using Java 9 is needed to scale the UI on Windows and Linux. (See http://openjdk.java.net/jeps/263 for details.) This also works for yFiles (tested in BinNavi).

Two flags need to be added to launch yEd properly.

java --add-exports=java.desktop/com.sun.java.swing.plaf.windows=ALL-UNNAMED --add-exports=java.desktop/com.apple.laf=ALL-UNNAMED -jar yed.jar

asked Jan 20 in Help by dave (120 points)
recategorized Jan 23 by thomas.behr

1 Answer

0 votes
hi. this fails in kubuntu 17.04 with openjdk-9-jre. please fix. the jar app freezes on splash screen, at "enabling module yed". thanks.
answered Sep 13 by anonymous

yEd does not support OpenJDK! Moreover, Java 9 is still beta - use an officially released Oracle Java 8 runtime environment to run yEd. The latest official Oracle Java 8 is 8u144 available from Orcale's Java SE Downloads site.

Is this (waiting for Java 9) going to be the official solution to the unusably small font size of yEd on Linux? I see people have been asking for this feature for *years*.. Is it really that hard to add an entry in the settings file to set the GUI font size?