Welcome to yEd Q&A!
Here you can ask questions and receive answers from other members of the community and yEd developers. And you can tell us your most wanted feature requests.

Why is Yed not showing my drawing anymore???

0 votes
Hi,
i have opened an older graphic file (GraphMl). Yed isn't showing the drawing at all (Not in Overview or main panel).
In the structure- tree all the elements are available.
Happens with Yed V 3.16.2.1 on two different computers (Same file).

What do do???

Regards
asked Jan 3 in Help by anonymous

1 Answer

0 votes

Sounds weird. If the elements appear in the tree in the Structure View, they should also show up in the canvas, of course...

Would it be possible for you to upload your GraphML file here? (See How to upload files to yEd Q&A? for related documentation.)

You can also inspect the elements yourself, of course:
When you double-click an element in the structure tree, that element will be centered in the canvas and also be selected. Now you can inspect the properties of the selected element in the Properties View (coordinates, width, height, color, etc.) to see what is maybe wrong with it.
You can also do a 'select-all' (Ctrl-A) and change all elements to have, for example, a uniform size of 30px width and height, or black color, etc.

answered Jan 3 by thomas [yWorks] (22,980 points)
Hi, it's really strange.

What I figured out:
- When is press '1 click layout' the software 'scrambles' my layout, but it is visible at once.
- When I use the 'Undo' function right behind it is still visible but in the way I designed it.
- The overview window is 'grey' and not showing my drawing.
- Once I click into the overview window my drawing disappears

Btw.:
I have checked your upload link. Do I have to be logged in for extended functionalitiy? I have no possibility to mark parts of my text as link and upload files.
My drawing contains 'sensible' information. Is there an other option?
Uploading should also work when you aren't logged in. If it really should not work, there is nothing wrong with registering, of course.
To delete sensitive information from a diagram you can use 'Tools' > 'Anonymize'.
Hmmmmhhh,
can't see all the Options that are shown in 'How to upload...'.
Can only see a simple textbox for adding my comment.

Doesn't matter if logged in, Firefox or IE
Ah, now I see. The 'How to upload...' description doesn't apply to adding a comment. You need to edit your original question and add the link there.
Editing an older answer doesn't work too (No possibility for uploading/ ling). I have no chance to edit my first post (Maybe 'cause it is written as unregistered user).
Is there a chance for a direct mail or shall I open a new thread?
Think I got it:
Looks like as soon as a thread is marked as 'answered' the commenting box with extended functionality is gone...