Download
as PDF

yEd Menu Bar

The menu bar has the following entries: File, Edit, View, Layout, Tools, Grouping, Windows, Help.

The File Menu

New

Opens an editor to begin a new document from scratch.

Open...

Opens an existing document from disk. A new editor is used for the document. It is possible to open several documents at once by means of a multi selection in the file chooser dialog.
See 'File Formats' for descriptions of supported file formats.

Open URL...

Opens an existing document from a remote address. A new editor is used for the document.
See 'File Formats' for descriptions of supported file formats.

Recent Documents

Contains a list of documents that recently have been loaded or saved.

Save

Saves the document from the current editor using the associated name.
See 'File Formats' for descriptions of supported file formats.

Save As...

Saves the document from the current editor. This lets you specify the file name and file format to be used.
See 'File Formats' for descriptions of supported file formats.

Export...

Exports the document from the current editor to a file. This lets you specify the file name and file format to be used. yEd supports different export file formats.
Note that graphs cannot be loaded from exported files. In order to save a graph in a format that can be read, please use 'Save As...' instead.

Close

Closes the current editor.

Print...

Opens a dialog which enables the user to print either the whole graph or the visible contents of the current view only. The size of the output can be controlled by either specifying a scaling factor to be applied before printing the graph or by specifying on how many page rows and columns the output should fit. When choosing the latter option the scaling factor will be adjusted automatically so that the graph nicely fits on the poster.

Print Preview...

Opens up a print preview dialog window which enables the user to preview the print results. Within the preview panel it is also possible to change all relevant print settings and immediately see their effects.

Preferences...

Opens a dialog which lets you specify the behavior and display of the editor. See The Preferences Dialog for more details.

Select Language

Choose from one of the available languages.

Quit

Saves the current editor settings and quits yEd. Upon a restart the saved settings will be initially applied to the application. Note that the settings will be stored within a sub-directory in the user's home directory.

The Edit Menu

Undo

Undoes the last modification to the document.

Redo

Redoes the last undo step.

Cut

Copies the current node selection and all induced edges to the clipboard and removes it from the document.

Copy

Copies the current node selection and all induced edges to the clipboard.

Copy to System Clipboard

Copies the whole document or in the presence of a node-only selection an axis parallel rectangle containing the selected nodes to the system clipboard.

Paste

Pastes the contents of the clipboard.

Paste Into Selected Group

If exactly one open group node is selected in the current editor, this action lets you paste the contents of the clipboard into that selected node.

Duplicate

If one or more nodes are selected, this action duplicates the selected nodes.

Add Child

If one or more nodes are selected, this action adds a new node to the diagram that is connected to all selected nodes.

Delete

Removes the current selection from the document.

Convert to Label

If one or more nodes are selected, this action converts them to labels.

Convert to Node

If one or more labels are selected, this action converts them to nodes.

Align Nodes

The actions in this submenu let you align the selected nodes. They are also available using the keyboard shortcuts displayed in the menu.

Select All

Selects all nodes contained in the document.

Deselect All

Clears the current selection.

Raise Selection

Moves the current selection to the front.

Lower Selection

Moves the current selection to the back.

Find...

Opens a dialog which lets you find elements in the graph structure. See The Find Dialog for more details.

Find Next

Highlights the next element that matches the criteria which were specified during the last call to Find.

Find Previous

Highlights the previous element that matches the criteria which were specified during the last call to Find.

Manage Palette...

Opens a dialog that allows to manage the palette and its sections.

Manage Custom Properties...

Opens a dialog that allows to edit custom properties.

Properties Mapper...

Opens a dialog that allows to map custom properties to visual properties.

Edit Label

Opens an editor to edit the label text.

Properties...

Displays the properties of the selected graph element(s).

The View Menu

Zoom In

Zooms into the current view one step.

Zoom Out

Zooms out of the current view one step.

Reset Zoom

Resets the zoom level to 100%.

Area Zoom

Zooms into the part of a graph that is specified by dragging a rectangle on the view.

Local Zoom

Enables a magnifying glass which can be used to zoom into the part of the graph that is around the mouse cursor.

Fit Content

Zooms and moves the viewport, so that the whole graph gets visible.

Center Selection

Displays the currently selected elements in the center of the view without changing the zoom level.

Go to URL

Opens the URL associated with a selected graph element.

Mode

This submenu can be used to switch to different modes. See The different view modes for a more detailed description of the different modes.

Edit Mode
This is the standard mode. It is used primarily for modifying the contents of the document.
Navigation Mode
This mode can be used to navigate more easily through the document. It is primarily used for browsing.

Snap Lines

Toggles the Snap Lines feature. Snap Lines help you to create a graph with an appealing layout interactively.

Grid

Enables/disables the grid in the view.

Orthogonal Edges

Toggles the Orthogonal Edges feature. The Orthogonal Edges feature lets you easily create and update orthogonal edges interactively.

Full Screen

Switches to full-screen mode which allows convenient navigation in the current document. (You can leave this mode again by pressing ESC.)

The Layout Menu

The layout menu provides access to the powerful layout algorithms that are part of the yFiles API. Layout Algorithms contains a more detailed description of the different options.

The Tools Menu

The tools menu provides access to a wealth of useful tools that can be used to gain information about, the currently edited document, modify the document visually and structurally and to create all new documents from scratch. Tools offers a more detailed description of the available tools.

The Grouping Menu

This menu provides access to the node hierarchy features that are available in yEd. These are described in more detail in Grouped and Nested Graph Hierarchy.

The Windows Menu

This menu is only available in the version of yEd that supports dockable windows. Dockable windows and their benefits are explained in the section "Dockable Windows".

Overview

Displays the 'Overview' tool window.

Structure View

Displays the 'Structure' tool window.

Properties View

Displays the tool window that presents the properties of selected nodes or edges.

Palette

Displays the 'Palette' tool window.

Reset Window Layout

Resets the arrangement of all default tool windows to their factory positions.

Editors

Holds the list of currently open editors.

The Help Menu

Help

Opens the yEd help window.

First Steps

Opens a tutorial that explains the yEd graph editor's essential usage concepts and possibilities.

Visit yEd Knowledge Base...

Opens a collection of tips and small tutorials for yEd in the web browser.

Example Graphs

Makes available a set of example graphs.

Welcome Screen

Displays the Welcome screen that is presented at application startup.

Send Feedback...

Opens a dialog for sending a message to yWorks. You can use this tool to send bug reports and feature requests to the yEd team at yWorks.

Check for Update...

Checks whether a newer version of yEd is available at the yWorks web site.

About

Displays version and legal information.